Running PTC Wildfire 2.0 & Wildfire 3.0
under linux Ubuntu 8.04 LTS - Installation guide


Remark: this page was originally created for Ubuntu 6.06,
but it works the same way under Ubuntu 8.04 LTS.
Required packages may have a newer version.
Ubuntu 6.06 LTS (Dapper Drake) kernel: 2.6.15-28-386
Wildfire 2.0 M260 Linux, also works with Wildfire 3.0 M100
Verify that you have these sources in: /etc/apt/sources.list
(I suppose that you have used Synaptic already).
  deb-src http://fr.archive.ubuntu.com/ubuntu dapper main restricted

  deb http://fr.archive.ubuntu.com/ubuntu dapper-updates main restricted
  deb-src http://fr.archive.ubuntu.com/ubuntu dapper-updates main restricted

  deb http://archive.ubuntu.com/ubuntu/ dapper universe main restricted multiverse
  deb-src http://fr.archive.ubuntu.com/ubuntu dapper universe

  deb http://fr.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
  deb-src http://fr.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse

  deb http://security.ubuntu.com/ubuntu dapper-security main restricted
  deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted

  deb http://security.ubuntu.com/ubuntu dapper-security universe
  deb-src http://security.ubuntu.com/ubuntu dapper-security universe
 
While installing the Pro/E Wildfire 2.0 or 3.0, you may get this error:
========ERROR==================================================================
libXm.so.3
===============================================================================

Install these packages. It will resolve the problem:
motif-clients, libmotif-dev, libmotif3

The second error is:
========ERROR==================================================================
libstdc++-libc6.2-2.so.3
===============================================================================
Install this package. It will resolve the problem:
libstdc++2.10-glibc2.2
After installing Wildfire, you may get the last error,
just when you launch proe1

========ERROR==================================================================
Cannot register service: RPC: Unable to receive; errno = Connection refused
===============================================================================
Install these packages:
nfs-common, libnfsidmap1
The "LANG" variable must be set to LANG=C
otherwise, you could get:
========ERROR==================================================================
x11r5_create_fontset: Unable to create fontset for (6x13,*--18-*).  Trying alternatives (6x13,*--18-*)
x11r5_create_fontset: Unable to create fontset for (6x13,*--18-*)
x11r5_create_fontset: Missing character set: ISO8859-1
x11r5_create_fontset: Missing character set: ISO8859-1
x11r5_create_fontset: Missing character set: JISX0208.1983-0
x11r5_create_fontset: Missing character set: KSC5601.1987-0
x11r5_create_fontset: Missing character set: GB2312.1980-0
x11r5_create_fontset: Missing character set: JISX0201.1976-0
x11r5_create_fontset: Missing character set: ISO10646-1

===============================================================================

If you still need more help, you could find me on icq: 127136740
There is a great page about installing Wildfire 2.0 on Kubuntu



This page was created by Pichon Gostaf

visitors counter